I’M so STUPID (CHE came unscrewed)

BrookeB

Well-Known Member
5 Year Member
Joined
Mar 3, 2012
Messages
418
Location (City and/or State)
Bodfish
So, I’ve been really happy with pebbles and her continued growth, she’s smooth and gaining weight and I’m happy. But yesterday I was so flipping stupid I could punch myself, yesterday I decided her closed chamber needed cleaning (it definitely did) so spent the majority of the day completely washing everything inside the enclosure and the actual tub itself. Then I added new substrate and all of her clean stuff. Yesterday was luckily one of our cooler summer days and it was only around 98 at the hottest part of the day. So she was in her outside enclosure for about two or three hours (at the time it was only about 95 and she has a ton of shade and a hide that’s in shade). Everything went really well and she was soaked and put back in her clean closed chamber. Her closed chamber looks great and the moldy smell was gone so I was happy.

This morning I woke up and she wasn’t out of her hide yet. She is normally out of her hide 30 minutes before her Lights even turn on... I thought it was weird, BUT then I thought that maybe she was just exhausted from being in her outside enclosure for so long (the outside enclosure is new so I also thought that she could just have been extra stressed from yesterday) and maybe a little stressed from her closed chamber being cleaned and changed (she hates change).. well after a few hours she still hadn’t come out. I got worried and I opened the top, I immediately knew I screwed up. I looked at the temperature and humidity gauge (it’s hanging on the wall in plain view) and was so disappointed in myself. It read 72 f and 89 Rh.. I saw these numbers EARLIER but I thought it was 89f and 72rh... somehow during all of this cleaning the CHE was unscrewed slightly and it wasn’t heating at all.. so now my girl has been without heat for probably around 16 hours or more and our houses temperature drops to 65-70 at night. I fixed everything and put her under the heat to try to warm her up a little but I’m worried. I made such a rookie move, I should have checked before putting her back. I have a temperature gun.. what is wrong with me.. We where doing so good this time with the baby and now I’m stressed. Ughhhh I’m so stupid.
 

zovick

Well-Known Member
5 Year Member
Joined
Nov 17, 2013
Messages
1,780
So, I’ve been really happy with pebbles and her continued growth, she’s smooth and gaining weight and I’m happy. But yesterday I was so flipping stupid I could punch myself, yesterday I decided her closed chamber needed cleaning (it definitely did) so spent the majority of the day completely washing everything inside the enclosure and the actual tub itself. Then I added new substrate and all of her clean stuff. Yesterday was luckily one of our cooler summer days and it was only around 98 at the hottest part of the day. So she was in her outside enclosure for about two or three hours (at the time it was only about 95 and she has a ton of shade and a hide that’s in shade). Everything went really well and she was soaked and put back in her clean closed chamber. Her closed chamber looks great and the moldy smell was gone so I was happy.

This morning I woke up and she wasn’t out of her hide yet. She is normally out of her hide 30 minutes before her Lights even turn on... I thought it was weird, BUT then I thought that maybe she was just exhausted from being in her outside enclosure for so long (the outside enclosure is new so I also thought that she could just have been extra stressed from yesterday) and maybe a little stressed from her closed chamber being cleaned and changed (she hates change).. well after a few hours she still hadn’t come out. I got worried and I opened the top, I immediately knew I screwed up. I looked at the temperature and humidity gauge (it’s hanging on the wall in plain view) and was so disappointed in myself. It read 72 f and 89 Rh.. I saw these numbers EARLIER but I thought it was 89f and 72rh... somehow during all of this cleaning the CHE was unscrewed slightly and it wasn’t heating at all.. so now my girl has been without heat for probably around 16 hours or more and our houses temperature drops to 65-70 at night. I fixed everything and put her under the heat to try to warm her up a little but I’m worried. I made such a rookie move, I should have checked before putting her back. I have a temperature gun.. what is wrong with me.. We where doing so good this time with the baby and now I’m stressed. Ughhhh I’m so stupid.
Any healthy tortoise should easily be able to take temps of 65-70 at night. I would instead guess that the inactivity is due to the fact that you "changed" everything in the enclosure rather than low temperatures.

I left my tortoises (Stars and Radiateds among others) outdoors at night in CT unless the temperature went below 50 degrees. Never had any problems from doing so.

Don't beat yourself up too much over this. Just wait a couple days and all should be fine.
 

Tom

The Dog Trainer
10 Year Member!
Platinum Tortoise Club
Joined
Jan 9, 2010
Messages
54,135
Location (City and/or State)
Southern California
So, I’ve been really happy with pebbles and her continued growth, she’s smooth and gaining weight and I’m happy. But yesterday I was so flipping stupid I could punch myself, yesterday I decided her closed chamber needed cleaning (it definitely did) so spent the majority of the day completely washing everything inside the enclosure and the actual tub itself. Then I added new substrate and all of her clean stuff. Yesterday was luckily one of our cooler summer days and it was only around 98 at the hottest part of the day. So she was in her outside enclosure for about two or three hours (at the time it was only about 95 and she has a ton of shade and a hide that’s in shade). Everything went really well and she was soaked and put back in her clean closed chamber. Her closed chamber looks great and the moldy smell was gone so I was happy.

This morning I woke up and she wasn’t out of her hide yet. She is normally out of her hide 30 minutes before her Lights even turn on... I thought it was weird, BUT then I thought that maybe she was just exhausted from being in her outside enclosure for so long (the outside enclosure is new so I also thought that she could just have been extra stressed from yesterday) and maybe a little stressed from her closed chamber being cleaned and changed (she hates change).. well after a few hours she still hadn’t come out. I got worried and I opened the top, I immediately knew I screwed up. I looked at the temperature and humidity gauge (it’s hanging on the wall in plain view) and was so disappointed in myself. It read 72 f and 89 Rh.. I saw these numbers EARLIER but I thought it was 89f and 72rh... somehow during all of this cleaning the CHE was unscrewed slightly and it wasn’t heating at all.. so now my girl has been without heat for probably around 16 hours or more and our houses temperature drops to 65-70 at night. I fixed everything and put her under the heat to try to warm her up a little but I’m worried. I made such a rookie move, I should have checked before putting her back. I have a temperature gun.. what is wrong with me.. We where doing so good this time with the baby and now I’m stressed. Ughhhh I’m so stupid.
We've all done it, or something similar. Not a big deal. Shouldn't cause any problem at all.
 

wellington

Well-Known Member
Moderator
Tortoise Club
5 Year Member
Joined
Sep 6, 2011
Messages
39,872
Location (City and/or State)
Chicago, Illinois, USA
I once forgot about my Tortoise and he took an 8hr soak in a 72 degree air conditioned room.
I did that twice to a very young leopard. All night he soaked. Water was very cold.
Oops lol
He has never been sick a day in his life and he is now 9 years old.
 

BrookeB

Well-Known Member
5 Year Member
Joined
Mar 3, 2012
Messages
418
Location (City and/or State)
Bodfish
Her enclosure is officially back to the right temperature and humidity and she is doing her rounds.. she was definitely sluggish at first but she does seem to have worked up as soon as the temperature was raised. Thanks for all the encouragement. I’m so overly stressed with this little cutie because of my past babies and how they would pass even when I was doing things “the right way”.. So now I guess I freak out when I screw up.. 😞🤷🏼‍♀️ she does seem ok now though. Maybe a little mad that the enclosure is a little different lol but she can learn to deal with that 😂
 
Top