Two new torts - still learning

Status
Not open for further replies.

New Redfoot Mom

New Member
5 Year Member
Joined
Dec 26, 2011
Messages
25
Location (City and/or State)
Cleveland, OH
Hi everyone! I have been playing around on the Forum now since just before Christmas. Many things I am still figuring out (both on the site & with the TORTS)!!! Trying to set up my profile & messaging capabilities from Droid phone (maybe part of the problem)... My young sons and I received a baby Cherryhead and a baby "high color" Redfoot from Santa. They are absolutely gorgeous and I have taken many pics from my phone, but have not mastered downloading yet. I have used the Forum already to make modifications to our lighting and enclosure set up with great success! Is there a way to "search" the site by topic? Current question involves bright white marks appearing near the bottom of the Cherry's shell. Hoping these are "growth rings" & not "shell rot"/something wrong :( Again, I cannot post a pic... HELP!
 

mintybum

Member
5 Year Member
Joined
Sep 12, 2011
Messages
53
Location (City and/or State)
Grimsby, Lincolnshire, UK
Hi
sound like growth rings if they white, they should be fine though, if they're wide then your over feeding them, i find my redfoots usually have them on the top of the shell but guess the bottom has to grow too, to search the forum just type significant words in the search bar at the top, there is a section for redfoots/cherryheads too.
New Redfoot Mom said:
Hi everyone! I have been playing around on the Forum now since just before Christmas. Many things I am still figuring out (both on the site & with the TORTS)!!! Trying to set up my profile & messaging capabilities from Droid phone (maybe part of the problem)... My young sons and I received a baby Cherryhead and a baby "high color" Redfoot from Santa. They are absolutely gorgeous and I have taken many pics from my phone, but have not mastered downloading yet. I have used the Forum already to make modifications to our lighting and enclosure set up with great success! Is there a way to "search" the site by topic? Current question involves bright white marks appearing near the bottom of the Cherry's shell. Hoping these are "growth rings" & not "shell rot"/something wrong :( Again, I cannot post a pic... HELP!



check this out too if you havent got the book already, its really informative.

http://books.google.co.uk/books?id=...ource=gbs_atb&redir_esc=y#v=onepage&q&f=false


New Redfoot Mom said:
Hi everyone! I have been playing around on the Forum now since just before Christmas. Many things I am still figuring out (both on the site & with the TORTS)!!! Trying to set up my profile & messaging capabilities from Droid phone (maybe part of the problem)... My young sons and I received a baby Cherryhead and a baby "high color" Redfoot from Santa. They are absolutely gorgeous and I have taken many pics from my phone, but have not mastered downloading yet. I have used the Forum already to make modifications to our lighting and enclosure set up with great success! Is there a way to "search" the site by topic? Current question involves bright white marks appearing near the bottom of the Cherry's shell. Hoping these are "growth rings" & not "shell rot"/something wrong :( Again, I cannot post a pic... HELP!
 

New Redfoot Mom

New Member
5 Year Member
Joined
Dec 26, 2011
Messages
25
Location (City and/or State)
Cleveland, OH
I searched for white rings, no luck. Still no luck adding pics, either. They are symmetrical white markings along the bottom of the shell. Looks to me like they could be centers of next set of scutes. Instead of yellowish like other center markings, they are a brighter white... I feed greens about size of torts shell, plus one Mizuri pellet moistened, per Tyler Stewart...
 

bubbles01

New Member
5 Year Member
Joined
Oct 25, 2010
Messages
562
Location (City and/or State)
Corfu, Greece
Welcome to TFO!

When you do your next post there is a box at the bottom for adding attachments, if you click it, find your file then upload it that should do it, then if you click "add attachment into post" (think thats the right wording) then your pics should show....
 

Yvonne G

Old Timer
TFO Admin
10 Year Member!
Platinum Tortoise Club
Joined
Jan 23, 2008
Messages
89,052
Location (City and/or State)
Clovis, CA
Welcome

We’re glad you’re here!!!
 

jkingler

New Member
5 Year Member
Joined
Jan 2, 2012
Messages
433
Welcome. Looking forward to those pictures! Happy with one tort, but always curious to see (and maybe eventually get) more. :)
 

ShadowRancher

Active Member
5 Year Member
Joined
Nov 8, 2011
Messages
966
Location (City and/or State)
Columbia, SC
Hello and welcome, I don't keep redfoots but you've come to the right place for questions. It sounds like normal (or possibly fast) growth to me. Hard to say without pictures though.
 

New Redfoot Mom

New Member
5 Year Member
Joined
Dec 26, 2011
Messages
25
Location (City and/or State)
Cleveland, OH
When I tried to attach photos just now, the error message read: the file uploaded failed. Please choose a valid file and try again... I guess I will download pics from phone to computer and try that way...

Thanks for the welcome everyone!
 
Status
Not open for further replies.
Top