Incubator malfunction

Status
Not open for further replies.

phiraphon

New Member
5 Year Member
Joined
Aug 15, 2010
Messages
16
I found my incubator was stopped working this morning. It seems like the fuse burnt out sometime last night. The temperature was about mid 70s when I found out about it. There are about 15 eggs and a few of them are piping.
I have no choice but have to transfer them to another incubator. The one that piped I can see the baby moving around. I am just concern about those that near hatch. Do you think they will be ok from temperature drop last night and the transferring this morning?
Thanks everyone
 

Tim/Robin

Well-Known Member
10 Year Member!
Joined
Jul 18, 2008
Messages
1,109
They should be fine, 70F isn't low enough to kill any developing or developed tortoises. Good luck.
 

ALDABRAMAN

KEEPER AT HEART
10 Year Member!
Joined
Nov 5, 2010
Messages
28,301
Location (City and/or State)
SW Forida
I agree with Tim/Robin, they should be almost fully developed.
 

phiraphon

New Member
5 Year Member
Joined
Aug 15, 2010
Messages
16
Thank you both for reply. Now I know the temperature dropped shouldn't harm them. How about the trauma of transferring them to the new incubator? I have to pick them up one by one to move them. Of course with the most diligent and careful not to rotate them.
 

ALDABRAMAN

KEEPER AT HEART
10 Year Member!
Joined
Nov 5, 2010
Messages
28,301
Location (City and/or State)
SW Forida
phiraphon said:
Thank you both for reply. Now I know the temperature dropped shouldn't harm them. How about the trauma of transferring them to the new incubator? I have to pick them up one by one to move them. Of course with the most diligent and careful not to rotate them.

:)
 

phiraphon

New Member
5 Year Member
Joined
Aug 15, 2010
Messages
16
11 out of 15 hatched so far :)
Thank you everyone for encouragement.
 
Status
Not open for further replies.
Top